Forums » CentiLeo for Cinema 4D
Pages: 1
Does "object buffer" not work with centileo? (multi-pass)
 
I am trying to get a luma track matte for an object to render out and use with After Effects. However, I have tried many variations and types of formats for rendering (EXR, PNG, etc.) but I cannot get the render to give me a multi-pass with a luma (white object on black background) to use.
I used the C4D composite tag which has object buffer, and I added object buffer to multi-pass with centileo render settings.
Am I doing anything wrong?
My object buffer 1 pass in the render is just a black screen, but there should be an object with the buffer in a tag.

I followed this tutorial to do it. https://www.youtube.com/watch?v=mycLyM2oU_c
Edited: ssjenforcer - Nov 12, 2021 11:08
 
哥们你微信多少啊?
mio_3d
我的微信加我
 
Administrator  Posts: 593
Nov 12, 2021 18:26
ssjenforcer, open CentiLeo render settings, there is AOVs tab. In this tab please make "Alpha channel" flag enabled. So, in IPR you will see the Alpha chanel buffer together with Beauty image. Also in Picture Viewer there will be both Beauty and Alpha images.
 
Quote
Kirgman wrote:
ssjenforcer , open CentiLeo render settings, there is AOVs tab. In this tab please make "Alpha channel" flag enabled. So, in IPR you will see the Alpha chanel buffer together with Beauty image. Also in Picture Viewer there will be both Beauty and Alpha images.
ok, thank you. I will try this.
I think I disabled that after realizing I didn't need it for compositing my Beauty pass.
 
Administrator  Posts: 593
Nov 12, 2021 19:22
For sure we need to implement the complete support of composite tag, this is very important. And also implement a lot more AOV/extra render buffer types. This is in a roadmap and not really hard to do. But currently are doing other important things :)
 
I tried and I cannot get the buffer to have anything rendered. Only the alpha channel looks like the buffer should and the buffer is just a black screen.
My buffer is applied to only one object, but the alpha shows all objects as white. I need the buffer to apply to a single object. And taking this saved frame doesn't allow me to have an alpha either way. When I use it in After Effects it is just the regular image with the objects looking normal. No alpha.

I don't want alpha channel, so is there a way to get object buffer to render properly?
Edited: ssjenforcer - Nov 13, 2021 14:53
 
Administrator  Posts: 593
Nov 13, 2021 15:29
I understand the problem. At the moment the selection of objects to get included into alpha channel or object buffer or any other mask buffer is not supported. But will do this in the future, there will be a lot of flexibility there because CentiLeo allows to render a lot of render buffers at once and keep really many images.
 
Quote
Kirgman wrote:
I understand the problem. At the moment the selection of objects to get included into alpha channel or object buffer or any other mask buffer is not supported. But will do this in the future, there will be a lot of flexibility there because CentiLeo allows to render a lot of render buffers at once and keep really many images.
ok. I do not need the feature too much right now. As long as I can figure out shadow catching with centileo to composite rendered objects I will be fine for now.
thank you.
 
Administrator  Posts: 593
Nov 14, 2021 05:18
Have you realiszed how to make shadow catcher?
So, assign a material to a plane where you want to get shadows drawn on a background. This material should have "Matte / Shadow Catcher" flag enabled in node-based materials. In different material implementations (node-based or not) there is either shadow catcher or matte name for this.
Also you can cast the shadows with different shadow intensity to this plane object from other scene objects. This shadow intensity can be controlled for Sky + CentiLeo environment tag, for Directional / Sun light source or Omni light source with CentiLeo light tag. In all light tag settings "shadow catcher" value changes the shadow intensity.
 
Quote
Kirgman wrote:
Have you realiszed how to make shadow catcher?
So, assign a material to a plane where you want to get shadows drawn on a background. This material should have "Matte / Shadow Catcher" flag enabled in node-based materials. In different material implementations (node-based or not) there is either shadow catcher or matte name for this.
Also you can cast the shadows with different shadow intensity to this plane object from other scene objects. This shadow intensity can be controlled for Sky + CentiLeo environment tag, for Directional / Sun light source or Omni light source with CentiLeo light tag. In all light tag settings "shadow catcher" value changes the shadow intensity.
No, I cannot get shadows to render at all. I tried shadow multi-pass and it just renders a black screen.
Edited: ssjenforcer - Nov 16, 2021 11:49
 
Pages: 1
Users browsing this topic