Forums » CentiLeo for Cinema 4D
Pages: 1 2 Next
CentiLeo lights, how do they work? I cannot make them more intense
Lights not able to brighten in IPR
 
I try to increase practically every setting for omni lights and even spotlights, but nothing really shows the light intensity increase very much at all.
The viewport shows the light getting stronger, but the IPR lighting is very weak and cannot get brighter, even when making the shape size several meters in radius. The scene just stays quite dark.
Overall Multiplier helps, but not after a certain point. And Light Pass does literally nothing as far as I can tell.
How do I brighten up an area using these lights?

Also, I had made a topic earlier but then deleted, because I made an omni light which did not light anything at first. It was only after increasing the radius that it lit up anything in my scene. I think the default radius for omni light is too small, as it does not light anything and only shows a small dot for the light itself, but does not illuminate the scene at all initially.
 
Administrator  Posts: 756
Nov 3, 2021 00:38
Does your light has CentiLeo light tag? There there is a Multiplier and there are Multipliers of intensity for Camera, Diffuse, Reflection and other layera. Increase them and increas the overall Multiplier.
Also please send me an isolated scene example that reproduces the problem either attaching here or to info@centileo.com. I will look there. Really all these multipliers work out of the box, maybe you hit some problem probably with scene scale or scene exposure or something like this.
 
Administrator  Posts: 756
Nov 3, 2021 14:57
ssjenforcer, how things are going? Still no message on our email
 
Sorry I just saw this reply. I will try tonight.
the multipliers are default at 1 and go from 0 to 1, so I can't increase them anymore anyway, right?

I usually keep the camera multiplier at 0 so the light does not show up in the render as a black void.
Edited: ssjenforcer - Nov 3, 2021 18:55
 
Administrator  Posts: 756
Nov 3, 2021 18:57
You can increase the multipliers larger than 1. Just type the value or use top-bottom arrows. 0-1 range is only for the left-right slider just to make the fixed range.
One guess is that you probably played with exposure too much or maybe with the scene scale. I just wanted to check this all by myself
 
Quote
Kirgman wrote:
You can increase the multipliers larger than 1. Just type the value or use top-bottom arrows. 0-1 range is only for the left-right slider just to make the fixed range.
One guess is that you probably played with exposure too much or maybe with the scene scale. I just wanted to check this all by myself
ok, I'll try that. By the way the slider looks it didn't seem like it went above 1. Maybe you can change it so that the slider can go higher, similar to the overall multiplier slider how it can go way higher and it's clear that it can?
 
Quote
Kirgman wrote:
You can increase the multipliers larger than 1. Just type the value or use top-bottom arrows. 0-1 range is only for the left-right slider just to make the fixed range.
One guess is that you probably played with exposure too much or maybe with the scene scale. I just wanted to check this all by myself
Thank you. That works.
 
User  Posts: 1
Nov 4, 2021 21:45
When I open the console Cinema4D, it crashes
 
Administrator  Posts: 756
Nov 4, 2021 22:01
DGFD, what Cinema version? What console? CentiLeo also has some debug console - is it what you open?
 
I am trying to figure out the Sun light now, and what does distance do? I change it and it does nothing to the position or intensity of the sun light.
Also, why is the lighting angle controlling how bright and large the sun light is?
I am just trying to get a normal sun light object to appear and light my scene as the real sun would, but ever time I make it the same size as the sun would really look by changing the lighting angle to something like 5 degrees, the light it produces gets very dim.
Why is the sun light so large (death star size) if I want the light it produces to look realistic?
 
Administrator  Posts: 756
Nov 9, 2021 05:21
The Sun Light object in CentiLeo menu is based on Cinema native Infinite light source + CentiLeo light tag. It has no position, it considers it's infinitelly long away from the scene. It only illuminates from a certain angle which is controlled by object coords.
If you want to change the shadow softness casted by object when illuminated by this light then just change the "Lighting angle" in CentiLeo light tag. Make it 1-30 degrees or anything.
If the light intensity become dim or very bright then change it either as Overall Multiplier in CentiLeo light tag or either as Intensity in General settings of this light object.
 
Quote
Kirgman wrote:
The Sun Light object in CentiLeo menu is based on Cinema native Infinite light source + CentiLeo light tag. It has no position, it considers it's infinitelly long away from the scene. It only illuminates from a certain angle which is controlled by object coords.
If you want to change the shadow softness casted by object when illuminated by this light then just change the "Lighting angle" in CentiLeo light tag. Make it 1-30 degrees or anything.
If the light intensity become dim or very bright then change it either as Overall Multiplier in CentiLeo light tag or either as Intensity in General settings of this light object.
But is the distance property supposed to affect anything?
 
Administrator  Posts: 756
Nov 9, 2021 12:58
No, in this case distance property inside Sun tag doesn't do anything. It moves the object near-far but the overal implementation is that it's infinitelly far. Maybe native Cinema renderer interprets it somehow like spot or area light source. Maybe in Cinema the Sun tag distance doesn't have effect for Infinite light sources at all, I haven't tested really.
 
Why don't the light types work such as square spot, parallel, and IES? They don't produce any light in the scene.
I am trying to make a light that will look like this.
 
Administrator  Posts: 756
Nov 25, 2021 01:14
These light types are simply not yet supported. This will be fixed.
Currently only those types are supported: area with rectangle shape, spot, infinite, omni.
The omni has radius parameter in centileo light tag to make a sphere from it.
Infinite light has lighting angle parameter in centileo light tag to change the softness of shadows.

Additionally there are mesh lights in CentiLeo. You can make any geometry object of any complexity and assign CentiLeo Emission material to it. In node space you just connect Emission node to the Output node or you can use a mix combination of Emission and non-emission materials and connected to Output.
There is a cylinder light shape on you picture. Just use CentiLeo mesh light, they are very fast.
 
I can't really understand what I am doing wrong. I am trying to light a room with all walls closed off, it has a floor and ceiling, and I have an area light at the ceiling to light the room. The area taken up by the light object is completely dark, and nothing I try can make the room ceiling light like the walls.
I added an omni light as well and that does not help at all.
How do I light the room without having this dark spot?

I move the light down but then the upper part of the ceiling is still dark but not very dark.
Is there no way to make a double-sided area light?

Also, when I try to change settings for the light in the Details tab and General tab any changes I make produce no changes to the light. Changing the falloff has no effect, area shape has no effect, etc.
What are we able to change for light settings?
Edited: ssjenforcer - Dec 22, 2021 00:55
 
Administrator  Posts: 756
Dec 22, 2021 08:41
The light source geometry simply occludes own indirect lighting. Make it smaller and add more internsity. Omni light source type (of course with centileo light tag) works here too, it will probably need to increase intensity or overall multiplier for much larger value than default.
 
Quote
Kirgman wrote:
The light source geometry simply occludes own indirect lighting. Make it smaller and add more internsity. Omni light source type (of course with centileo light tag) works here too, it will probably need to increase intensity or overall multiplier for much larger value than default.
Ok, I forgot intensity can go above 100%.
I turned it to 200000% and my light object is very small, like 0.1m x 0.1m, to avoid the dark shadow on the ceiling, and my scene looks much better. And my light multiplier is 10.


Also, decreasing my area light size so much, wouldn't that make my shadows sharper? If I wanted to make them softer how would I do that if increasing the area light size isn't an option?
Edited: ssjenforcer - Dec 23, 2021 00:38
 
Administrator  Posts: 756
Dec 23, 2021 02:59
In the viewport everything is so white because of intensity. Instead of increasing intensity in general settings you can increase the overal multiplier in centileo light tag. It's not in percents but a scaling factor for the same thing. This multiplier will not increse the lighting in the viewport of Cinema but will increase the intensity in the renderer.
Quote
ssjenforcer wrote:
Also, decreasing my area light size so much, wouldn't that make my shadows sharper? If I wanted to make them softer how would I do that if increasing the area light size isn't an option?
That's the physics of light source geometry. Larger light source area will make softer shadows. Just increase the light source radius using the option "shape radius" in centileo light tag. Larger radius will produce larger area of light source surface and larger intensity. This intensity can be decreased with multiplier. Just play with these settings :)
 
Do I need to touch the shadow setting under the light objects?
I learned that shadow is default set to none, but does centileo have a shadow setting already that is accurate, or is it better to change it to area?

Also, is it more accurate to turn on Global Illumination for this renderer?

I notice subtle differences with different shadow settings and GI, but I don't know if they are necessary with Centileo.

I notice now that GI Illumination is checked by default for the light objects, but GI in render settings enabled gives me a different lighting beneath the objects.

To me it looks best with GI enabled in render settings and Area set for shadow. Is this correct?
Edited: ssjenforcer - Feb 20, 2022 05:56
Pages: 1 2 Next
Users browsing this topic (1 guests)