Forums » CentiLeo for Cinema 4D
Pages: Prev. 1 2
Shadow catch pass (multi-pass) does not work under any settings
shadow catch never shows up, and I have tried many combinations of settings
 
Quote
Kirgman wrote:
Glad, you fixed this! Btw there are also options in C4D file saving something like "Straight Alpha", "Pre-multiplied Alpha".
Also in CentiLeo render options (in AOVs tab) there is "Transparent Background" option that also kills the reflection of background on reflections as far as I remember
I always just use the default. Maybe the other would help a bit?
right now when I adjust the Alpha to reduce shadow strength in AE I lose a tiny bit of the beauty layer edge.
 
Administrator  Posts: 643
Dec 9, 2021 02:17
Actually only experiments will help to find the right settings here. On CentiLeo side we will implement a lot of AOVs (extra images), mask images, some funtionality to combine them in the output. It's all possible because we have a very good architecture to support the render and output of really many images at once.
 
Quote
Kirgman wrote:
Hi, this is a sample with shadow catcher setup:
https://drive.google.com/file/d/188S8wvb097fdrAGZp3cqNorji6loOMm2/view?usp=sharing

1. Image 001.png. Make a Ground Plane object (higlighted), assign CentiLeo material to it, in material Diffuse settigns check Shadow Catcher flag as highlighted on the image.
2. Image 002.png. Setup your HDR lighting. Sel ect the file of hdr as shown here. You may optionally override the HDR for couple of contributions (coming from Reflection, Camera or Diffuse, etc). In this example we override the texture for Reflections. They will be drawn from some other Sky Override object. We also override Matte Shadow contribution, it will cast the shadows from "Sky Override" lighting to the Ground Plane object.
Also you can change the strength of shadows that are casted on the Ground Plane. The shadows can be casted from HDR Sky objects as described above and from Sun light source (with CentiLeo light tag) and fr om Omni light souce (also with CentiLeo light tag). To manage the shadow strength of each light source you may change the "Matte Shadow Weight" as hightlight on 002.png
3. Image 003.png. To get the mask of object and shadows just open the CentiLeo render settings, AOVs/passes Tab, and in that place please enable "Alpha channel" flag as highlighted on the image. This way you be able to select Alpha chanel pass in IPR window as you can see. Also this pass will be provided inside Picture Viewer render together with Beauty image.
4. Image 004.png. To get the image with transparent background and the semi-transparent shadows on top of that just enable "Transparent background" option as highlighted on the image.

The shared sample has this .c4d file with textures.

Kirill
I am still having issues with a scene.
I cannot get any shadows to render in the alpha no matter what I try.
Here is the scene with no shadow catcher applied, and here is the alpha of the same scene with shadow catcher applied.
There is no shadow at all. I am not sure what to try. I have tried adjusting my HDRi settings and everything I can think of.
My other scenes have worked and I have the same settings I have always used, but now with this one it doesn't render shadows for alpha.
Edited: ssjenforcer - Dec 13, 2021 00:42
 
I tried disabling all my lights, and this seems to show this now for the alpha.
But why would the lights on the tree not affect the shadow on the regular plane but burn out all shadow on the shadow catcher plane?
Does it have something to do with that each of the cloned lights on the tree has shadow matte weight?

But even stranger is when I disable the lights I am left with a new shadow that shouldn't exist.
There should only be a shadow behind the tree, but no matter what I do my HDRi is somehow making a shadow in front of the tree that I cannot remove, but it only shows up in the alpha when I enable shadow catcher. Otherwise the shadow isn't there.

And this shadow that shouldn't exist appears even if I turn the HDRi multiplier down to almost zero, including the shadow weight for it.
Edited: ssjenforcer - Dec 13, 2021 01:45
 
Does this make any sense? Even when changing my HDRi, lowering all the settings, even rotating it does not change the shadow shown here.
I can't make any sense of this.
It only does this when I apply the shadow catcher. When I uncheck it the shadows all act normally.
Edited: ssjenforcer - Dec 13, 2021 02:41
 
Administrator  Posts: 643
Dec 13, 2021 08:46
That remaining shadow in front of the tree is probably casted using the light source that is not switched off. The bottom line status bar says there are 8 light sources in the scene.
How did you implemented the colored light sources on the tree?
1) If they are regular cinema omni lights with centileo light tags then by default they will cast shadows on the shadow catcher. In this case you can set shadow catcher matte weight to zero for all such lights.
2) If you have implemented the colored light sources on the tree with the spheres and emission material then they will not produce the shadows for the shadow catcher object and will not affect it. This is a preffered way for render speed for this scene if you don't enable imprortance sampling for such emission materials because their lighting is local.
If you want the shadow catcher object to receive the shadow only from the one light source or Sky HDRI then only this object (using CentiLeo light tag or environment tag) should have shadow catcher / matte weight equal to 1. And all other unwanted light sources should have shadow catcher / matte weight equal to zero.
 
Quote
Kirgman wrote:
That remaining shadow in front of the tree is probably casted using the light source that is not switched off. The bottom line status bar says there are 8 light sources in the scene.
How did you implemented the colored light sources on the tree?
1) If they are regular cinema omni lights with centileo light tags then by default they will cast shadows on the shadow catcher. In this case you can set shadow catcher matte weight to zero for all such lights.
2) If you have implemented the colored light sources on the tree with the spheres and emission material then they will not produce the shadows for the shadow catcher object and will not affect it. This is a preffered way for render speed for this scene if you don't enable imprortance sampling for such emission materials because their lighting is local.
If you want the shadow catcher object to receive the shadow only from the one light source or Sky HDRI then only this object (using CentiLeo light tag or environment tag) should have shadow catcher / matte weight equal to 1. And all other unwanted light sources should have shadow catcher / matte weight equal to zero.
Ok, I had disabled the check on my cloner objects but neglected to also uncheck my lights that were childs of the cloner, and so they were still emitting light in the scene and casting that shadow.
Turning all their shadow weights to 0 fixes everything.
It was just confusing me that the beauty showed a certain shadow and the alpha showed extra shadows.
Is there any reason that the two modes would show different shadows, when having and not having shadow catcher enabled? Is there a way to make them show the same shadows in both modes, particularly when viewing IPR? I had already checked those two boxes you mentioned that show the same lighting in IPR and render view
Or is the simplest way to remember to change my shadow weights for every light source?
Edited: ssjenforcer - Dec 13, 2021 12:21
 
Administrator  Posts: 643
Dec 15, 2021 12:09
Quote
ssjenforcer wrote:
Ok, I had disabled the check on my cloner objects but neglected to also uncheck my lights that were childs of the cloner, and so they were still emitting light in the scene and casting that shadow.
Turning all their shadow weights to 0 fixes everything.
Basically in the case for this scene it can be faster to make these colored light souces on the Christmass tree with sphere objects and apply an Emission material on them with "imtportance sample" off. The render may become faster if these lights produce local lighting, not global.
Quote
ssjenforcer wrote:
It was just confusing me that the beauty showed a certain shadow and the alpha showed extra shadows.
Is there any reason that the two modes would show different shadows, when having and not having shadow catcher enabled? Is there a way to make them show the same shadows in both modes, particularly when viewing IPR?
They should be the same on the shadow catcher plane. But they may look different based on the color conditions, the alpha channel is black and white and it may show the shadow masks more clearly on a black background.
Quote
ssjenforcer wrote:
Or is the simplest way to remember to change my shadow weights for every light source?
Basically only few types of light sources can contribute to the shadow strength that is casted to the shadow catcher object:
1) Sky + HDRI using CentiLeo environment tag, it has shadow weight.
2) Directional (Infinite) regular light with CentiLeo light tag, it has has shadow weight.
3) Regular light of Omni type with CentiLeo light tag, it has has shadow weight.
Other types of light sources (area, spot) don't produce shadows on the shadow catcher plane. If you want to exclude some lights from producing the shadows then just make shadow weight equal to zero. Or make it a smaller number to make this shadow weaker compared to others. This feature is nice itself and has potential to future improvement.
 
Quote
Kirgman wrote:
Quote
ssjenforcer wrote:
Ok, I had disabled the check on my cloner objects but neglected to also uncheck my lights that were childs of the cloner, and so they were still emitting light in the scene and casting that shadow.
Turning all their shadow weights to 0 fixes everything.
Basically in the case for this scene it can be faster to make these colored light souces on the Christmass tree with sphere objects and apply an Emission material on them with "imtportance sample" off. The render may become faster if these lights produce local lighting, not global.
Quote
How do you apply an emission material? I don't see Emission in the centileo material anywhere as a property to check, otherwise I might have tried that.


EDIT:
Oh, I see it is in the node editor. But is there not a way to add it using the material editor instead of having to use nodes?
Edited: ssjenforcer - Dec 16, 2021 01:37
 
Administrator  Posts: 643
Dec 16, 2021 03:01
In case you use node material editor there is an Emission material node that can be used to plug into Output node or it can be combined with Material using MixMaterial.
Otherwise you can use simple not-node based materials, this way an Emission channel is available inside the Standard CentiLeo Material together with Reflection, Diffuse, Alpha and other channels.
 
Quote
Kirgman wrote:
In case you use node material editor there is an Emission material node that can be used to plug into Output node or it can be combined with Material using MixMaterial.
Otherwise you can use simple not-node based materials, this way an Emission channel is available inside the Standard CentiLeo Material together with Reflection, Diffuse, Alpha and other channels.
The only thing would be maybe a checkbox could be added beside those like diffuse and alpha, because when I add the emission node and wish to edit it I must open the node editor first and click the node for it to appear in the material editor. Otherwise if I click off or do something else the emission property disappears from the material editor until I go back to the node editor.
couldn't the check box to enabled/add emission be there always when making a material?
Edited: ssjenforcer - Dec 16, 2021 20:42
 
Administrator  Posts: 643
Dec 17, 2021 10:26
These two screenshots describe two ways of Emission material setup:
1) Using nodes. Here the emission node is connected using the mix material with a bitmap to manage where it's an emission or reflective material. To avoid hiding the bottom left menu of available shaders just click at the button inside red rectangle to stick it on top of other windows. This is native Cinema 4D R25 interface feature, not CentiLeo. To my mind in R23 it was more convenient node interface.


2) This picture shows how to setup emission material using standard old centileo material, here a checkbox on the left is needed to be enabled and manage all the settings in Emission tab. Of course managing complex texture relationships with nodes is much easier.
 
Oh, I was using the centileo node material and just using the space here to handle my settings.
Is the old centileo material just as good in terms of updated tools?

I just thought that the node one could have also had the emission right beside the other properties to make it easier to enable it.

And as far as I can tell there is no way to customize the palette for C4D to have the old material icon where I keep my other centileo tools.

EDIT:
Interesting, I didn't notice before but using the old material instead of the node makes the colour applied to objects visible in the viewport, unlike the node material.
Edited: ssjenforcer - Dec 17, 2021 14:07
 
Administrator  Posts: 643
Dec 17, 2021 13:58
Actually the node materials appeared in CentiLeo since Cinema R21. And for me it seems that old materials will eventually be outdated at some time, they seem to be kept in flight just for legacy reasons. And news features seems to be added to node materials more actively. For this reasons for R21-R21 CentiLeo sets the node material command to it's menu. It has more features (nodes, connections) :) I also was thinking to split out SSS from standard material to the separate SSS material just to save some space.
Pages: Prev. 1 2
Users browsing this topic