Forums » CentiLeo for Cinema 4D
Pages: 1
Render will show HDRi background image in picture viewer but is transparent black background in After Effects?
 
I can't figure it out. I have never had this issue before.
I rendered the same as I always have. 32 bit OpenEXR.
I have transparent background unchecked.
Does this make any sense?
 
I just tried doing a multipass with background and diffuse and reflection passes, and that seems to allow me to have a composited background image from the HDRi.
But why would this not work for a regular saved render?
The picture viewer clearly shows that the background was rendered into the OpenEXR, so why would I not be able to see it in After Effects?

Could there be a bug that is preventing the background from being saved to the image file even though it is being rendered?
Edited: ssjenforcer - May 26, 2022 12:18
 
Administrator  Posts: 762
May 30, 2022 21:21
Hi ssjenforcer, sorry for delayed reply!
The Transparent background option removes the HDRI image from the main render image. You can save this background if you check the "Bacgkround" pass.
But maybe your issue is related to the "Alpha channel" option in Render->Save option?


 
I thought the alpha channel only matters if there is actually an alpha with no background.
I assumed the background would make it not have alpha and save the background instead.
Thanks.
By the way, how is the next update coming?
I hope it is coming along well :D
 
Have you checked premultiply by matte option in After effects?
Some times disabling the matte in interpret footage may show the background.
 
footage>interpret footage>alpha>ignore
 
Administrator  Posts: 762
Jun 1, 2022 10:12
Quote
ssjenforcer wrote:
By the way, how is the next update coming?
I hope it is coming along well
Well, it's so long under development, that's too much, too complex. And no new features. Only fixes and some important render optimizations for hard cases. Need some bit more time and will launch it, hopefully without major bugs :)
 
Quote
thrimanakatha wrote:
footage>interpret footage>alpha>ignore
good point. I will try that.
it makes sense because I'm certain the background must have been saved as the picture viewer shows.
Pages: 1
Users browsing this topic (3 guests)